Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Unable to log into SWIS Suite

Jeanette Sherwood Dyer-Kelly Elem. Jan 13, 2017 03:03PM PST

The screen for the SWIS Suite is "white" blank when I log in. This has been an issue all day long. Please advise if the system is down? or Do I need to do anything to correct the problem? Thank you for your help.

Up -1 rated Down
Beatriz Jan 13, 2017 03:31PM PST PBISApps.org Support Staff

We released an update last night 1/12/17 which may cause some users the need to clear their browsing history. Once you clear the history and relaunch the browser you should be able to login and navigate to SWIS.

This question has received the maximum number of answers.



Contact Us

We're available 7 AM–4 PM Pacific, Monday–Friday

Post a Public Question Email Us

Phone & Fax

Phone: 855-455-8194
Fax: 541-346-2471

Mailing Address

1235 University of Oregon
Eugene, OR 97403-1235

Sign Up for the PBISApps Newsletter

Subscribe to our quarterly newsletter to stay up-to-date with all our news, updates, and releases!

Image of two speech bubbles

We're Here to Help!

Search our support forum or ask a question.
We're also available by chat, email, or phone when you need live help!    Go to Support »

Products

SWIS Suite:   SWIS   |   CICO-SWIS   |   ISIS-SWIS

PBIS Assessment   |   PBIS Evaluation

Let Us Help You

Video Tutorials   |   Materials

Training   |   Support   |   Contact Us

Join the Conversation

Copyright © 2016 Educational and Community Supports, All Rights Researved   |   Confidentiality & Security   |   Customer service software powered by Desk.com

In affliation with the    University of Oregon

pbisapps@gmail.com
http://assets1.desk.com/
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
Invalid characters found
/customer/en/portal/articles/autocomplete